SQL Server 資料庫組態設定工具線上說明

SQL Server 資料庫連線設定 上層主題

使用 SQL Server 資料庫組態設定工具，您可將 Apex One 伺服器連線到現有的其他 Apex One SQL 資料庫，並且變更用來連線到您現有資料庫的登入認證。
使用 SQL Server 資料庫組態設定工具可執行下列作業：
  • 切換到其他已存在的 Apex One SQL Server 資料庫實體
  • 更新現有 SQL Server 資料庫的登入認證
  • 設定當 SQL Server 資料庫無法使用時的警訊設定
相關資訊
  • 使用 SQL Server 資料庫組態設定工具
  • 設定 SQL 資料庫無法使用警訊
© 2020 Trend Micro Incorporated / 趨勢科技股份有限公司。保留所有權利。


使用 SQL Server 資料庫組態設定工具

Trend Micro homepage

SQL Server 資料庫組態設定工具線上說明

使用 SQL Server 資料庫組態設定工具 上層主題

使用 SQL Server 資料庫組態設定工具，您可將 Apex One 伺服器連線到現有的其他 Apex One SQL 資料庫，並且變更用來連線到您現有資料庫的登入認證。

步驟

  1. 在 Apex One 伺服器電腦上，瀏覽至 <伺服器安裝資料夾>\PCCSRV\Admin\Utility\SQL。
  2. 按兩下 SQLTxfr.exe 執行此工具。
    「Apex One SQL Server 資料庫組態設定」主控台會隨即開啟。
  3. 按照如下格式指定「伺服器名稱」：<SQL Server 的主機名稱或 IP 位址>,<通訊埠號碼>\<實體名稱>
    重要
    重要
    安裝 SQL Server 時，Apex One 會自動建立 Apex One 資料庫實體。移轉至現有 SQL Server 或資料庫時，請在 SQL Server 上輸入 Apex One 實體的先前存在的實體名稱。
  4. 提供 SQL Server 資料庫的驗證憑證。
    • 使用「Windows 帳號」登入伺服器時，Apex One 會套用目前登入之使用者的「使用者名稱」。
      重要
      重要
      使用者帳號必須屬於本機管理員群組或 Active Directory (AD) 內建管理員，而您必須使用 Windows「本機安全性原則」或「群組原則管理」主控台設定「使用者權限指派」中的下列原則：
      • 以服務方式登入
      • 以批次工作登入
      • 允許本機登入
      使用者帳號還必須具有下列資料庫角色：
      • dbcreator
      • bulkadmin
      • db_owner
  5. 在「資料庫名稱」區段中，指定 SQL Server 上的 Apex One 資料庫名稱。
  6. 如果您在安裝期間設定了 Endpoint Sensor 資料庫，請指定 Endpoint Sensor 資料庫名稱。
    注意
    注意
    如果您的 Endpoint Sensor 資料庫位於與 Apex One 資料庫不同的 SQL 執行個體中，請參閱下列常見問題集文章，以瞭解如何管理資料庫。
    https://success.trendmicro.com/solution/1122929
  7. 或者，執行下列工作：
    • 請點選「Apex One 資料庫無法使用警訊...」，設定 Apex One SQL 資料庫通知設定。
      如需詳細資訊，請參閱設定 SQL 資料庫無法使用警訊。
    • 請點選「測試連線」，確認現有 SQL Server 或資料庫的驗證憑證。
  8. 請點選「開始」，套用組態變更。
© 2020 Trend Micro Incorporated / 趨勢科技股份有限公司。保留所有權利。


設定 SQL 資料庫無法使用警訊

Trend Micro homepage

SQL Server 資料庫組態設定工具線上說明

設定 SQL 資料庫無法使用警訊 上層主題

每當 SQL 資料庫無法使用時，Apex One 會自動傳送此警訊。
警告
警告
當資料庫變得不可用時，Apex One 會自動停止所有服務。當資料庫不可用時，Apex One 無法記錄用戶端或事件資訊、執行更新或設定用戶端。
「資料庫無法使用」警訊僅適用於 Apex One 伺服器資料庫，不適用於 Endpoint Sensor 資料庫。

步驟

  1. 在 Apex One 伺服器電腦上，瀏覽至 <伺服器安裝資料夾>\PCCSRV\Admin\Utility\SQL。
  2. 按兩下 SQLTxfr.exe 執行此工具。
    「Apex One SQL Server 資料庫組態設定」主控台會隨即開啟。
  3. 請點選「Apex One 資料庫無法使用警訊...」。
    「Apex One 資料庫無法使用警訊」畫面隨即開啟。
  4. 輸入警訊收件者的電子郵件信箱。
    請使用半形分號 (;) 來分隔多個項目。
  5. 視需要修改「主旨」和「訊息」。
    Apex One 提供下列 Token 變數：

    Apex One 資料庫無法使用警訊 Token

    變數
    說明
    %x
    Apex One SQL Server 實體的名稱
    %s
    受影響的 Apex One 伺服器的名稱
  6. 請點選「確定」。
© 2020 Trend Micro Incorporated / 趨勢科技股份有限公司。保留所有權利。