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This documentation introduces the main features of the product and/or
provides installation instructions for a production environment. Read
through the documentation before installing or using the product.

Detailed information about how to use specific features within the product
maybe available at the TXOne Online Help Center and/or the TXOne
Knowledge Base.

TXOne always seeks to improve its documentation. If you have questions,
comments, or suggestions about this or any TXOne document, please
contact us at

docs@trendmicro.com.

Evaluate this documentation on the following site:
http://docs.trendmicro.com/en-us/survey.aspx
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Privacy and Personal Data Collection Disclosure

Certain features available in TXOne products collect and send feedback
regarding product usage and detection information to TXOne. Some of this
data is considered personal in certain jurisdictions and under certain
regulations. If you do not want TXOne to collect personal data, you must
ensure that you disable the related features.

The following link outlines the types of data that TXOne StellarOne
collects and provides detailed instructions on how to disable the specific
features that feedback the information.
https://success.trendmicro.com/data-collection-disclosure

Data collected by TXOne is subject to the conditions stated in the Trend
Micro Privacy Notice:
https://www.trendmicro.com/privacy
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Preface

The Administrator's Guide introduces TXOne StellarOne and covers
allaspects of product management.
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Audience

TXOne StellarOne documentation is intended for users responsible
for StellarOne management including agent installation,
management, and the command line interface. Administrators are

expected to have advanced networking and server management
knowledge

viii
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Document Conventions

The following table provides the official terminology used throughout the
TXOne StellarOne documentation:

Table 1. Document Conventions

Secured by

One

Convention Description
UPPER CASE Acronyms, abbreviations, and names of certain commands and keys on
the keyboard
Bold Menus and menu commands, command buttons, tabs, and options
Italics References to other documents
Monospace Sample command lines, program code, web URLs, filenames,

and program output

Navigation > Path

The navigation path to reach a particular screen
For example, File > Save means, click File and then click
Save on the interface

J Note

Configuration notes

2,

Recommendations or suggestions

=
¥ Important

Information regarding required or default configuration settingsand

product limitations

A WARNING

Critical actions and configuration options
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The following table provides the official terminology used throughout the
TXOne StellarOne documentation:

Table 1. StellarOne Terminology

Terminology

Description

server

The StellarOne console server program

server endpoint

The host where the StellarOne server is installed

agents

The hosts running the StellarProtect program

NAT agents

The agents that are built under the routers with the
Network Address Translation (NAT) function enabled

managed agents
managed endpoints

The hosts running the StellarProtect program that are
known to the StellarOne server program

target endpoints

The hosts where the StellarOne managed agents will
beinstalled

Administrator
(or StellarOne
administrator)

The person managing the StellarOne server

Stellar console

The user interface for configuring and managing
StellarOne settings and managed agents

CLI

Command Line Interface

license activation

Includes the type of StellarOne server installation and
theallowed period of usage that you can use the
application
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Chapter 1

Introduction

This chapter introduces TXOne StellarOne and how it manages agents
providing Industrial-Grade Next-Generation Antivirus protection to your
assets. An overview of management functions is provided here.
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About the TXOne™ Stellar™ series
and StellarOne™

TXOne’s Stellar series is a first-of-its-kind OT endpoint protection platform,
allowing protection for modernized and legacy systems running side-by-
side to be coordinated and maintained from the same management
console, which includes:

« StellarOne™, the ONE console for Stellar series products
. StellarProtect™, the Industrial-Grade Next-Generation Antivirus

+  StellarEnforce™, for application lockdown with on-demand AV scan

Field devices in OT production can be categorized into modernized and
legacy machines, with legacy machines making up the majority. On
systems running legacy OSes, which are also likely to have limited
computing resources, StellarEnforce is a perfect fit for ICS customers.

For the modern machines being brought into the OT environment more
intelligence and flexibility are necessary! For this reason, TXOne
Networks’ engineers developed a new ICS endpoint protection platform,
StellarProtect. StellarProtect & StellarEnforce work in concert to
provide comprehensive endpoint protection for ICS assets, managed from
the StellarOne console.
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Agent Features and Benefits

TXOne™ StellarOne™ includes the following features and benefits.

Table 2-1. Features and Benefits

Feature Benefit

StellarOne provides a configurable dashboard from which
customers can get real-time StellarProtect information,
including the endpoints with the most blocked events, top
blocked files, CPU usage, memory usage, and disk usage.

Dashboard

When the device installs StellarProtect it will register to
StellarOne automatically.

Device Management These agents will be managed by StellarOne, and you canadd a
group or groups to manage agents as well as configure them
with individual or group-based policies.

StellarOne has 4 types of events and logs, which provide users
Events/Logs with analysis and management functions. Using the notification
Management function, administrators and auditors can query and analyze
events to quickly find the root cause of the problem.

StellarOne supports several functions specifically for
managing endpoints running StellarProtect:

1. Account Management
2. Single Sign-On
3. System Time

Administration 4. Proxy

Management
5. Downloads / Updates

6. SSL Certification
7. License

8. Log Purge
9. Firmware
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What’s New

TXOne StellarOne 1.2 Patch 1 includes the following new features and
enhancements.

Table 2-2. What's New in TXOne StellarOne 1.2 Patch 1

Feature Description
Group Mapping User can register StellarProtect agent to a specific
group directly via StellarOne web console.
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Chapter 2

Agents

This chapter introduces how to manage StellarProtect agents through StellarOne.
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About the Agents Screen

To display the Agents screen, go to Agents in the navigation at the top of the
web console. This screen displays a list of agents managed by StellarOne
console and allows you to perform configuration tasks.

—ﬁNote:

All agents are under the All group by default. ™ jcon indicates a group and

L icon indicates an agent.

stellarOne

Dashboard Agents
Agents Al (2) - Cl=  name - Q
F Aaa Grou 1 = c
Name IP Address Protection Group Policy Inheritance  Agent Version Last Connection Product Actions
0 WX s = 2 w2esse 7 @ A o nnertea 121028 2022.04.0271615:48+08:00 ©
[ Peazdd 192 168.154.138 a A ® nnerited 121028 2022.04-02T16-1547+05.00 Lo
i WFSQLPrabeA-B (0 - - - nhertied v
. Taman (0 - - - heriied v
B8 Proberhisning (0) B . . herteg o
B winntuin ni (0) nerted o
I C Wwindowsuain mertiea ©:
nhertied ©:
heriied v
nerited v
o
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Manage the Agent Tree

StellarOne allows you to organize the agent tree and manage StellarProtect
agent information.

Task Detail

IAdd agent groups Create groups according to location, type, or
purpose to help you manage multiple agents.

Reorganize agent groups Reorganize groups. (Suggested to add the section
about the task.)

Rename agent groups Change the names of groups.

Remove agent groups/ Remove groups or unregister agents from the

Unregister agents StellarOne console.

Search for agents or groups [Search for agents/groups with additional search

criteria.

Add Groups
Procedure
1. Go to Agents in the navigation at the top of the web console. The Agents
screen will appear.
2. Start from the All group on the Agent view.
3. Click the group name to navigate to a target parent group to create a
new group.
4. Click o+ A Grow button on the above control area.
5. The Add Group window will appear.

Input the group name and select Confirm
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—“jNote:

The maximum length limitation of group name is 50 characters.
The maximum number of levels is 15.

Rename Groups

Procedure

1.

arw N

Go to Agents in the navigation at the top of the web console. The Agents
screen will appear.
Select the target group you want to rename.

Click * , More icon of Actions and click Rename.
The Rename Group window will appear.
Input the new name you want to use and click Confirm.

—‘/jNote:

The group name cannot be the same as the same level.

Remove Groups / Unregister Agents

Procedure

1. Goto Agents in the navigation at the top of the web console. The Agents
screen will appear.

2. Select the target groups you want to remove or the agents you want to
unregister.

3. Click * , More icon of Actions and click Remove.

4. The Remove Items confirmation window will appear.

5. Click Confirm that you want to remove the group or unregister the agent.
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—'4Note:

If the target group is not empty (with any groups or assets), it cannot be
removed.

Search for Agents/Groups
Procedure

1. Go to Agents in the navigation at the top of the web console. The Agents
screen will appear.

2. Search for specific endpoints by selecting criteria from the drop-down list
and specify additional search criteria as required.

Option Description
Agent The name of the agent. Type the full or partial endpoint host
name to locate the specific agent.
IP Address Type the IPv4 address.
IP Range Type the IPv4 address range.
Group The name of the group. Select the available group.

Policy Inheritance [The mode of Policy Inheritance. Select Inherited or
Customized.

Policy Deployment [The status of policy deployment from StellarOne to Agents.
Select Completed or In Progress.

Agent Version Type the Agent Version.

Last Connection Last connection time. Select the default time range or select
Custom to specify your own range. Default time range:
. Last 1 hour
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Option Description
. Last 24 hours
o Last 7 days
o Last 30 days
Product Select StellarEnforce or StellarProtect.

Operating System

Select an operating system.

Description

Type the full or partial description to query specific endpoints.

10
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Chapter 3

Policy Management

This chapter introduces how to manage StellarProtect agents with policy.

11
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Manage Group/Agent Policy

e The user can add the group with agents, and then inherit Group Policy from

the parent group or customize its own Group Policy.

¢ The agent can also have its own customized Agent Policy instead of
inheriting from the parent group.

e The user can switch the product (StellarProtect or StellarEnforce) to display
its Policy and General Info.

Dashboard Agents Logs ¥ Adminisiration + About
Agents All (5)> Taiwan (3) > Taoyuan (3) ~ o~
+ Add Group 1 " e::]
Agent IP Address Protect... Policy Agent .. Operating System Last Connection Product Actions
] Pc3sss 192.168.154.138 @ ® Cuslomized 121014 Windows 7 Professional Service Pack 1 buld 7...  2022-02-24T16:3. 0
[ Pczoo8 192.168.66.128 1] ® Inherited 121064  Windows Server 2008 R2 Enterprise Edition (b...  2022-02-24T13:2. 0
[ Pc2003 192.168.154.145 a8 @ Inherited 111014 Windows Server 2003 R2, Enterprise Edition S 2022-02-24T16:3 4 StellarEnforce L

< @ Taoyuan (3)

Product  StellarEnforce - Policy Inheritance @ ) Inherit from parent group: Taiwan

< LJPC2003

Policy Inheritance @ ) Inherit from parent group: Taoyuan

12
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Industrial-Grade Next-Generation Antivirus

The industrial-grade next-generation antivirus settings include ‘Real-Time

Scan’ and ‘Schedule Scan’. The settings are as follows:

Industrial-Grade Next-Generation Antivirus
ICS root of trust and advanced threat scan secure the assets while no interruption on the operations

£ L) Real-time malware scanning

Advanced Threat Scan

> Advanced Options

[ Schedule Scan

> Advanced Options

Real-Time Scan

Real-time Scan is a persistent and ongoing scan. Each time a file is received,
opened, downloaded, copied, or modified, Real-time Scan scans the file for
security risks. If the Security Agent does not detect a security risk, users can
proceed to access the file. If the Security Agent detects a security risk or a
probable virus/malware, a notification message displays indicating the name of

the infected file and the specific security risk.

Real-time Scan maintains a persistent scan cache which reloads each time
the Security Agent starts. The Security Agent tracks any changes to files or folders
that occurred since the Security Agent unloaded and removes these files from the

cache.

13
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Predictive Machine Learning

Predictive Machine Learning uses advanced machine learning technology to
correlate threat information and perform in-depth file analysis to detect emerging
unknown security risks through digital DNA fingerprinting, APl mapping, and other
file features. Predictive Machine Learning also performs a behavioral analysis on
unknown or low-prevalence processes to determine if an emerging or unknown

threat is attempting to infect your network.

Predictive Machine Learning is a powerful tool that helps protect your environment

from unidentified threats and zero-day attacks.

Industrial-Grade Next-Generation Antivirus
ICS root of trust and advanced threat scan secure the assets while no interruption on the operations.

@) Real-time malware scanning
Advanced Threat Scan

> Advanced Options
@ Sschedule Scan | ER Schedule

> Advanced Options

@ Important

Advanced Threat Scan is configured to support all scan types,

including scheduledscans.

Schedule Scan

14
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If you want to set an antivirus scan schedule, click ‘Schedule Scan’, and then click
the ‘Schedule’ icon to set the date and time.

[ ) schedule Scan ‘ ‘

| o

The schedule settings are as follows:

. Frequency
o Daily
o Weekly, and choose a day from Monday to Sunday

o Monthly, and choose a day of the month (keeping in mindthat for
monthly scanning to proceed each month that daymust exist in every
month, for example scanning set to take place on the 30" would not
proceed in February)

. Start time

o Set the hour and minutes

15
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Schedule X

Frequency: @ Daily
'.:.' Weekly, every Sunday v

() Monthly, onday 01

Start time: 04 v : 00 W

Cancel

16
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Advanced Options

You can configure the following settings for industrial-grade next- generation
antivirus under ‘advanced options’:

. Files to Scan
You can choose one of the following scopes to adjust for scan targeting:
- All'local folders
- Default folders for quick scan
- Specific folders

If you select “Specific folders”, then you can add a folder listby clicking
the '+

You can enable ‘scan removable drives’ when you need the endpoint

to scan connected external storage devices.

The ‘Scan compressed files. Maximum layers:’ setting allows multiple

layers of compressed files to be scanned, providing better scan
coverage.

17
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Scanning large files might cause performance issues, so you can

configure the file size limit to skip files over a certain size.

Files to Scan

Scan compressed files. Maximum layers:| 1 w

Skip files larger than| 30 ME (1-9999)

Scan Action

O Quarantine
Mo action

If threats are detected in any file, you will be prompted to choosea

scan action.

You can choose an action as follows:
- Quarantine

- No action

You also can choose some folders or files with config file
extensions. StellarProtect will skip these folders and files to meetOT

environment requirements.

18
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Scan Exclusions

Exclusion can be configured for Realtime scan and Schedule scan: you can add

multiple folders, files and file extensions for excluding in scan.

Exclusion folder will include its subfolders. For example, C:\Windows will also
exclude all folder/files in C:\Windows\Temp and other folders. In short, it

excludes all files/folders inside C:\Windows\

Wildcard is not necessary for all exclusions, input your desired setting is enough.
File extension exclusions: don’t need “.” Or “*.” In front of the file extension.
Currently, remote path exclusions are not supportable. For example, Error!

Hyperlink reference not valid. nor \\[Hosthame] are not supportable yet.

19
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Operations Behavior Anomaly Detection

As fileless attacks can cause serious damage, StellarProtect provide
‘Operations Behavior Anomaly Detection’ to prevent such attacks.

Operation Behavior Anomaly Detection

Learn: Add unrecognized calls from monitered operations and processes to the Approved List
Detect: Create a log of unrecognized calls from monitored operations and processes

© Enforce: Block unrecognized calls from monitored operations and processes
Disable

Aggressive Mode

[ watchilist (0)

Learn Mode

After activating this function, StellarProtect will monitor unrecognized
program calls and add them to the approved list to learn more about ICS-
related program call behaviors.

Detect Mode

After activating this function, StellarProtect will monitor unrecognized
program calls and log them for future analysis.

Enforce Mode

After activating this function, StellarProtect will monitor unrecognized
program calls and block them to secure the endpoint.

20
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Disable

When Operations Behavior Anomaly Detection is set to Disable,
protection is turned off.

The Operations Behavior Anomaly Detection function additionally has an
Aggressive Mode, and can activate protection through process
parameter recognition.

Users can check the process and parameters under monitoring.

Watchlist / Monitored Processes

You can add more processes to be monitored. StellarProtect will monitor
Powershell.exe, wscript.exe, cscript.exe, mshta.exe, and psexec.exe

by default.

Operations Behavior Anomaly Detection Watchlist
( ‘
\ |

Monitored Process

Please input the process name and click ‘OK’ to confirm.

Add Monitored Process X

Process:
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DLL Injection Protection

DLL injection prevention is an important and well-known form ofendpoint security.

DLL Injection Protection

Enable DLL Injection Protection

Block DLL Injection

To enable this protection, click ‘Enable DLL Injection Protection’.

DLL Injection Protection

. g\’j Enable DLL Injection Protection

OT Application Safeguard

OT Application Safeguard is industrial-based change control protection.

Users can enable this protection to make sure StellarProtect-recognized ICS
applications can be updated without being blocked or restricted.

In addition, you can enable ICS application protection to secure recognizedICS
application executable binary files.

Basically, StellarProtect will auto-detect currently-installed OT/ICS application

and put them under protection. Note that OT/ICS application showing in
General info tab, this indicates StellarProtect recognizes this application.
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For newly-installed OT/ICS applications, be sure to enable “Maintenance Mode”
before installing the new application. After the installation process is completed,
disable the Maintenance mode and then it will auto re-scan OT/ICS applications.
If any new applications are found, they will be added into the OT/ICS Application
Safeguard list.

If your OT/ICS application doesn’t show, the administrator can manually add
installation path for the application under Safeguard’s protection.

In OT/ICS Application Safeguard policy setting pane, click File/Folders. Then
manually add application installation path. The default is to protect this
folder/subfolder PE file (.exe & .dll), if you want to protect all files inside this
folder, there is also have one option “Executable file only” can be disabled to
protect all files inside this folder. Administrator can also protect their secret
files/configurations or other files from being modified with the untrusted
applications.

Administrator can also set other application to be the trusted application to modify
the protected file by adding the Authorized process. However, please note that if
any malicious file has been set into the Authorized process, Stellar Protect
cannot prevent this file from modifying OT/ICS application since it is already
become excluded from the StellarProtect’s monitor process. Make sure this
process is safe before adding the Authorized Process.
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Trusted Certificates

The policy Trusted Certificates provides an import function allowing the
administrator to add new trusted certificates.

Process with trusted certificate can modify / update / change Protected
file/folders.

Trusted Certificates (0)

- oot

Issued To Issued By Hash Actions

Click the ‘Import’ icon to import a new trusted certificate.

Trusted Certificates (0)

[ |

Click ‘Select File’ to browse certificate files.

Import Trusted Certificate X

Certificate File:* | Select File

Cancel
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Select the specific certificate file.

@ Open

- v 4 I > ThisPC > Desktop * v O 2 Search Desktop

Organize v New folder
» I 3D Objects A Name
I Desktop

Status Date modified Type Size

v

Debugging Tools for Windows (x64)
& Slack
» ¥ Downloads » s(euagne(;\
>« jteam (10.1.195.

> d Music
= Pictures
> ! Videos
> & SYS(C)
>« DAT (D) v <

2/3/2021 1:36 PM

> |5 Documents

[ONON ]

1/20/2021 517 PM Security Certificate

File name: v| [FRARE ot

Then click the ‘Import’ button to finish the function.

Import Trusted Certificate X

Select File | StellarOneCA.cer

Certificate File:

Cancel

You can have an updated certificate list here.

Trusted Certificates (1)

Issued To Issued By Hash

Actions

MyCompany MyCompany 2ff3ec80¢78387290632b802940f317fc8907247

(51
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Device Control

USB vector control is one of the foundations of endpoint protection, by which
StellarProtect supports USB storage device access control.

In StellarProtect agent side, when USB device control been enabled, every time
plug-in USB device, will prompt one dialog to confirm if admin really want to access
this device. But the confirm will need check every time, only add the USB info into

this list, will make this device always can directly access without check.

Device Control (0)
[ ) Block external device access for USB drives on managed endpoints. You can configure exceptions to allow access for the fellowing trusted USB devices

| + Add |

Vendor ID Product ID Serial Number Actions

No data to display

You can add specific drivers to the approved list.

StellarProtect supports VID (Vendor ID), PID (Product ID), and SN (Serial Number)
as conditions for USB vector control approval, and the administratorcan choose

one, two, or all to be used.

Please click ‘Add’ to add a new device.

EZD

You can input one or all of VID, PID and SN.
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Add Trusted USB Device X

Specify at least one of the following information for the trusted USB device.

Vendor ID: 04C5

Product ID: 1526

Serial number: 1179522

Note: You can use one of the following methods to get the information of a connected device to
an endpoint:

(1) Open the Device Manager on the agent endpoint
(2) Use opemd.exe -p ush info -d <drive_letter> command on the agent endpoint

You can check the updated USB vector list to confirm that the vector wasadded

successfully.

Device Control (1)

@) Block external device access for USB drives on managed endpoints. You can configure exceptions to allow access for the following
trusted USB devices.

-+ Add

(] VendorID Product ID Serial Number Actions

[ 4cs 1526 1119522 Pl
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Edit Trusted USB Devices

Procedure

1.
2.

Ok w

Find the Device Control pane in the Policy view.

Click the Toggle Switch to enable “Block external device access
for USB drives on managed endpoints. You can configure
exceptions to allow access for the following trusted USB

devices”. The Trusted USB Device List will appear.
Select the Trusted USB Device you want to edit.

Click the Edit button and the dialog window will appear.
Click the Confirm button and the settings will be saved.

Remove Trusted USB Devices by Setting Policy

Procedure

1. Find the Device Control pane in the Policy view.

2. Click the Toggle Switch to enable “Block external device access
for USB drives on managed endpoints. You can configure
exceptions to allow access for the following trusted USB
devices”. The Trusted USB Device List will appear.

3. Select the Trusted USB Device you want to delete.

4. Click the Delete button and the Remove Trusted USB Device dialog
window will appear.

5. Click the Confirm button and the settings will be saved.
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User-Defined Suspicious Objects

Sometimes we can receive new IOC (Indicators Of Compromise), including file

hash (SHA-1 or SHA-2) or path. You can add them and make sure all managed

endpoints are free of these infected files.
If there have new threat want to block, can set the file hash into User-Defined

suspicious object to block file been executed.

User-Defined Suspicious Objects

Protect against objects not yet on your network:

Hash / File Path Type Notes Actions

No data to display

Agent Password

This function allows OT administrators to change the StellarProtect admin

password for all connected endpoints via StellarOne.

Agent Password

New Password*
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Please input your new password twice and click ‘Save’ to finish policy setting.

Agent Password

MNew Password® | seessses ‘

Re-type Password” ‘ ........ | ‘

Password Policy

The password must be 8 to 64 alphanumeric characters. The following

characters are not supported: | > *: <\ spaces

Patch

The Patch function allows the administrator to upgrade all agents under the
same group policy to upgrade to a new version. The patching process will be

conducted remotely and automatically using policy sync.

Only one patch (Agent version) is allowed under each unit policy.
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—'/jNote:

Because StellarProtect is able to use global policies for all
agents as well asgroup policy for group-owned machines to
conduct the patching process on multiple devices, before you
select agent version please note the following:

1. Global policy is the default agent landing policy,
so every agent will apply this policy first before
moving to other groups. We suggest that the
global policy should use lower agent version asits
base policy.

2. If you don't want to set any agent version to be
patched, pleaseremember to clear all checkboxes
in ‘agent version’ under the Patch function.

@ Important

StellarProtect Agent 1.0 does not support Remote Patch, as it

does not have anyavailable remote patches.
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Chapter 4

Agent Protection

This chapter introduces how to manage StellarProtect Protection feature
command.
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Configure Maintenance Mode

The maintenance mode is necessary for changes in OT endpoint operations.
During the Maintenance mode, all newly-added files will be updated through real-
time virus scanning. Thus, StellarProtect can learn the newly-added applications
and ensure the execution of these newly-added applications under the protected
conditions. The user should perform the necessary application updates before the
Change Window reaches its assigned time to close. Please note that StellarProtect

will still prevent malware infection during the Change Window.

Scan Now

You can initiate ‘Scan Now’ through the StellarOne console and can targetone

or several StellarProtect agent endpoints.

Procedure
1. Go to Agents in the navigation at the top of the StellarOne
console.
2. Select one or more entries and then click Protection > Scan
Now.
3. When the confirmation screen appears, confirm your

settings and thenclick OK.

a. To scan compressed files, check Scan
compressed files andchoose the desired number
of layers.

b. To skip files larger than a certain size, check Skip files larger
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than and specify the size at which files should be skipped.

c. To scan with no trust rules, scanning everything with
current viruspatterns, check Aggressive scan.

The server will send a notification to the selected StellarProtect agents.

You can check the logs for the scan status.
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Chapter 5

Agent Update

This chapter introduces how to update StellarProtect scan component and
agent itself.
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Update Agent Components

You can start the agent component update process on selected endpoints from
StellarOne. The agent will thendownload the latest component updates.

Update agent components regularly to protect endpointsfrom the latest security
risks.

Procedure
1. Go to Agents > StellarProtect in the navigation at the
top of the webconsole. The Agents screen will appear.
2. Select one or more endpoints.
3. Select Protection > Update Agent Components.
4. Click OK.

Deploy Agent Patch

You can update agents directly from the web console page by usingStellarOne
to deploy an uploaded patch file to selected StellarProtect agents.

Procedure
1. Go to Agents > StellarProtect. The Agents screen will appear.
2. Select one or more agents.
3. Click Update > Deploy Agent Patch.
4. Select the available patch file for deployment.
5. Click OK.
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Chapter 6

Monitoring StellarProtect

This chapter introduces TXOne StellarOne monitoring feature.
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About the Dashboard

Monitor events from the Dashboard using the overview provided under the
Summary tab. This tab is added to the Dashboard by default when there are no
user-defined tabs.

Default widgets included in the Summary and System tabs with Blocked Event
History, Top Endpoints with Blocked Events, CPU Usage, Memory Usage, and
Disk Usage.

Top Endpoints with Blocked Events

This widget displays the endpoints with the most blocked events. By default, the
widget is displayed on the Event Overview tab of the Dashboard.

Column Description

Endpoint Name Name of the endpoint

Description Description assigned to the endpoint

IP Address IP address of the endpoint

Blocked Events Total number of events blocked on the endpoint
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StellarProtect Top Endpoints with Blocked Events

n=
Time Period: Last 7 days

Endpoint Name Description IP Address Blocked Events

TC - 192.168.15.138 1

Use the Time Period drop-down to display only the event data for the period
specified. To specify the number of events to display, open the Widget Settings
dialog, then select a different value for Events to display.
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Top Blocked Files

This widget displays a list of files that triggered the most blocked events, and it
will NOT be listed in the Dashboard by default.

Column Description

File Name Name of the file that triggered the blocked events

File Hash SHAZ1 hash of the file that triggered the blocked events
Endpoints Number of endpoints which reported a blocked event for the file
Blocked Events Total number of blocked events reported for the file

StellarProtect Top Blocked Files

Time Period: Last 7 days

File Name

Crtest\eicar\eicar.com

File Hash Endpoints Blocked Events
275a021bbfb6489e54d471899f 1 1
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CPU Usage

This widget displays CPU usage information.

CPU Usage

CPU Usage n=

CFU Usage &.73%

0% 8.7% 100%
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Memory Usage

This widget displays memory usage information.

Memory Usage
Memory Usage n=
0 Bytes 3.74 GB 3.86 CB
A

Disk Usage
This widget displays disk usage information.

Disk Usage

n=

Disk Usage

Disk Usage 153%

" |

0 Bytes 10.81 GB 7232cCE
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Add Widgets

The number of widgets that you can add to a tab depends on the layout for the
tab.

Once the tab contains the maximum number of widgets, you must remove a
widget from the tab or create a new tab for the widget.

Procedure
1. Go to Dashboard in the navigation at the top of the web console.
2. Go to the tab (Summary or System) on the dashboard that you
want to add the widget to.
3. Click Add Widgets and the screen appears.
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Dashboard Agems Logs ! Administration * About
Dashboard
R steiererrorce Top Endpoints wih Blocked Evens
System (3) Displays the endpaints that triggered the highest number of blocked events.
Ez D _'--'..'-.
D StellarEnforce Blocked Event HISIOW
Displays blocked events during a specified time period.
Ez D .'..'...-.
D StellarEnforce TOD Blocked Files
Displays the most frequently blocked files
zi D .'..'...n.
Add Cancel | Currently selected widgets in this tab (3/10).
4. Select one or more widgets to add to the current tab and then

click Add.
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Using Widgets

Perform the following tasks on each widget:

Task Steps
Move a widget | Move widgets on tabs by clicking and holding on the title bar at
the top of the widget and dragging to various locations on a tab.

Resize a Drag the edge of each widget to resize.

widget

Refresh widget | Config the Auto Refresh Settings under Widget Settings first.
data (Default value is Every 30 Seconds)

Widget Settings

Widget Name StellarEnforce Top Endpoints with Blocked Evel
Time Period: Last 7 days -

Auto Refresh Settings

Every 30 Seconds -

Manual Refresh

v Every 30 Seconds m Cancel

Every 1 Minute

Every 3 Minutes

Every 5 Minutes
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Task Steps
Rename a 1. Click the More Options icon at the top of the widget.
widget 2. Select Widget Settings. The Widget Settings screen appears.
3. Type a meaningful widget name for the widget.
Widget Settings X
Widget Name | |
Time Period: Last 7 days -
Auto Refresh Settings Every 30 Seconds -
m Cancel
Close awidget | 1.  Click the More Options icon at the top of the widget.
2. Select Remove Widget.
£} Widget Settings
» Remove Widget
Blocked Eve... ?'\:J
51 15
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Task Steps
Set Time Displays the data during the specified time period. (Default value is
Period Last 7 days)

Widget Settings

Widget Name StellarEnforce Top Endpoints with Blocked Evel
Time Period: Last 14 days -
Auto Refresh Settings Last 7 days -

v Last 14 days |

Last 30 days m Cancel

Last 3 months

Last 6 months
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About the Agent Events Screen

To display the Agent Events screen, go to Logs > Agent Events in the
navigation at the top of the web console. This screen displays a list of events
related to detection and activity monitored on agents managed by StellarOne.

Depending on the feature status, StellarProtect generates a log and performs the
action for the events listed in the following table.

Event Feature Status StellarProtect Action
A threat file landing or |[Real time scan disabled |Allows the file to
try to run landing/execute.

Real time scan enabled [First action in configure will be
taken and prompt for user a
chance to change action.

/A USB storage device Device Control disabled |Allows access for the device
attempts to access the

endpoint Device Control enabled [Denies access for the device
(when the device type is
removable device) and prompts
for user action

Unknown call of Operation Behavior Allows call trigger monitored
monitored process Anomaly Detection process.
disabled
Operation Behavior Block or Allow depend on mode
Anomaly Detection setting and prompt for user
enabled action.
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The following table describes the user actions for the events.

User Action Description

/Add to Approved List |Add the threat file to Approved List.

Restore & Add to Restore the quarantined file and add it to Approved List to
Approved List prevent detection of the same file.

Quarantine Quarantine the threat file.

Add to Approved Add unknown process chains to Operation Behavior
Operations IAnomaly Detection’s Approved List.

Allow one-time USB  |Allow blocked USB device access until next plug-in.
device access
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Querying Agent Event Logs

Querying refines the list of displayed agent event logs.

Procedure

4.

Go to Logs > Agent Events in the navigation at the top of the web
console. The Agent Events screen will appear.

To filter by period, click the Time Period drop down, which
defaults to Last 30 days, and pick a time period. Perform one of
the following:

. Click a listed time range.

. Click Custom, specify a time range, and click Search.

To filter by Endpoint Name, Agent Group, IP Address, IP Range,
Description, Event Type, Severity Level, click the drop-down to
the left of the search bar and specify a criteria.

. Endpoint Name: Specify the name of the endpoint you’re
looking for.

. Agent Group: Specify the name of the group you're
looking for.

. IP Address: Specify the IP address of the agent you're
looking for.

. IP Range: Specify a range of Ips to search for agents
within.

. Description: Specify the description assigned to the
endpoint

. Event Type: Select a specific event and click Apply.

. Severity Level: Select Information or Warning as the
event level.

The table displays only the entries that match the filters selected.
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Exporting Agent Events

Save data about selected agent event log entries as a CSV file.

Agent Events

StellarProtect  StellarEnforce:

Expodt Selected {3 Laval e gapem Acen

* e 0 2

Procedure

1. Go to Logs > Agent Events in the navigation at the top of the
web console. The Agent Events screen will appear.

2. Select the agent log entries in the list that you want to export
information for.

3. To export all entries, click the Export All on the upper-right.

4. To export selected entries only, select the entries you wish to
export, then click the Export Selected button in the upper-left.

5. Save the file.
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About the Server Events Screen

To display the Server Events screen, go to Logs > Server Events in the
navigation at the top of the web console.

Server Events

StellarProtect  StellarEnfore  StelarOne

This screen displays a log of audited StellarOne user account activity for
StellarProtect, StellarEnforce, and StellarOne.

ﬁNote:

Server event logs contain collected information about actions taken by
StellarOne web console account users and policies.

Querying Server Event Logs

Querying refines the list of displayed server event logs.

Procedure

1. Go to Logs > Server Events in the navigation at the top of the
web console. The Server Events screen will appear.

2. Click the drop-down list under Server Events. A list of search
criteria will appear.

3. Select the desired search criteria. Appropriate search fields
appear for the selected criteria.

4. Follow the appropriate steps depending on the selected criteria:
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Option Description

Time Period Do one of the following:

. Select a listed time range.

. Specify a custom time range.

a. Go to Custom in the list.

b. Specify your custom time range.
C

Click Apply.
User Name Displays all events logged by a specific user.
Endpoint Name Type the endpoint host name (first few letters or complete
name), and click Search.
Group Name Displays all events logged by the specific groups.
Event Type Select a specific event.

Your search results will appear in the list of server event logs.

Exporting Server Event Logs

Save data about selected server event log entries as a CSV file.

Procedure

1. Go to Logs > Server Events in the navigation at the top of the
web console. The Server Events screen will appear.

2. Select the server log entries in the list that you want to export
information for.

3. To export all entries, click the Export icon.

4. To export selected entries only, select the entries you wish to
export then click Export Selected.

5. Save the file.
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About the System Log Screen

To display the System Log screen, go to Logs > System Logs in the navigation at
the top of the web console. This screen displays a log of adjustable StellarOne
web console settings.

Querying Server Logs

Querying refines the list of displayed server event logs.

Procedure
1. Go to Logs > System Logs in the navigation at the top of the web
console. The System Log screen will appear.
2. Select the desired search criteria. Appropriate search fields
appear for the selected criteria.
3. Follow the appropriate steps depending on the selected criteria:
Option Description

Time Period Do one of the following:

e Select a listed time range.

¢ Specify a custom time range.
a. Go to Custom in the list.
b. Specify your custom time range.
c. Click Search.
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Option Description
Severity Select one of the criteria below and click Search.
e Emergency
e Alert
e Critical
e Error
e Warning
* Notice
e Information
¢ Debug
Your search results will appear in the list of system logs.
Exporting System Logs
Save data about selected system log entries as a CSV file.
Procedure
1. Go to Logs > System Logs in the navigation at the top of the web
console. The System Logs screen will appear.
2. Select the system log entries in the list that you want to export

information for.

To export all entries, click the Export icon.
To export selected entries only, select the entries you
wish to export then click Export Selected.
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About the Audit Log Screen

To display the Audit Log screen, go to Logs > Audit Logs in the navigation at the
top of the web console. This screen displays StellarOne’s audit logs.

Querying Audit Logs

Querying refines the list of displayed server event logs.

Dashboard Agents Logs « Administration ~ About

Audit Logs UserlD « Q Latest 1000 records »  Last 30 days ~
v UserID
[~ Export + 3 selected Client IP 1 11 :::] o
5 Time Severity User Severity Client IP Message -
2022-02-26T722:24:35+08:00 Notice Sammy 10.28.78.236 User (Sammy) login
2022-02-26T721:49:51+08.00 Notice admin 10.1.192.5 User (admin) login
Procedure
1. Go to Logs > Audit Logs in the navigation at the top of the web
console. The Audit Log screen will appear.
2. Select the desired search criteria. Appropriate search fields
appear for the selected criteria.
3. Follow the appropriate steps depending on the selected criteria:
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Optlon Descrlptlon
Time Period UseriD = Q Latest 1000 records v || Last30days +
Last 1 hour
1 I Last 3 hours
D client IP Message Last 12 hours
Last 24 hours
my 10.28 78.236 User (Sammy) login
Last 3 days
in 10.1.192.5 User (admin) login
Last 7 days
in 10.28.78.236 User (admin) login  Last 30 days
in 10.28 78.236 User (admin} login failed Last 90 days
my 10.28.78.236 User (Sammy) timeout, force logout Custom range

Do one of the following:

e Select a listed time range.

e Specify a custom time range.
a. Go to Custom in the list.
b. Specify your custom time range.
c. Click Search.

User ID Type user ID and click Search.
Client IP Type client IP number and click Search.
Severity Select one of the criteria below and click Search.

Audit Logs Severity v - Q
Emergency
[~ Export v 3 selected Alert
Critical
=| Time Severity Use
Error
@ 2022-02-26T22:24:35+08:00 Notice San  waming
B 2022-02-26T21:49:51+08:00 Notice adm Notice
Information =
B 2022-02-26T21:41:52+08:00 Notice admin 1028778236 User (admin) login
2022-02-26T721:41:50+08.00 Warning admin 10.28.78.236 User (admin) login failed
e Emergency
o Alert
e Critical
e Error
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Option Description
e Warning
* Notice
e Information
e Debug

Your search results will appear in the list of audit logs.
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Exporting Audit Logs

Save data about selected server event log entries as a CSV file.

—_
stellarOne & admin (admin) + ExOne
ot
Dashboard Agenls. Logs Administration « About
Audit Logs Jserip = Q Latest 1000 records Last 30 days =
= Export ~ 3 selected 1 " B s
Export Selected (3) Severity UseriD Client IP Message -
I
Bxport Al 4:35+08:00 Notice Sammy 10.28.78.236 User (Sammy) login
@ 2022-02-26T21:49:51+08°00 Natice aamin 10.1.192.5 User (agmin) login
B 2022-02-26T21:41:52+08:00 Notice admin 10.28.78.236 User (admin) login
2022-02-26T21:41:50+08.00 Warning admin 10.28.78.236 User (admin) login failed
2022-02-26T21:33:35+08:00 Notice Sammy 10.28.78.236 User (Sammy) timeout, force logout

1. Go to Logs > Audit Logs in the navigation at the top of the web
console. The Audit Logs screen will appear.
2. Select the system log entries in the list that you want to export
information for.
. To export all entries, click the Export All.
. To export selected entries only, select the entries you
wish to export then click Export Selected.
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Chapter 7

Administration

This chapter introduces TXOne StellarOne administration settings.
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About the Account Management Screen

To display the Account Management screen, go to Administration > Account
Management in the navigation at the top of the web console.

Use this screen to manage StellarOne web console accounts. TXOne StellarOne
web console accounts have the following privileges:

Account Type | Privileges

Admin a. Manage StellarOne: The privilege of configuring system
(FU” Control) settings_
b. Manage Group: The privilege of creating, moving, or deleting
groups.
C. Account Management: The privilege of managing StellarOne
accounts.

d. Policy Configuration: The privilege of defining policy for Agents
such as USB Control and Intelligent Runtime Learning.

Operator a. Manage Group: The privilege of creating, moving, or deleting
(Asset Control) groups.

b.  Policy Configuration: The privilege of defining policy for Agents
such as USB Control and Intelligent Runtime Learning.

Viewer a. Read only for Dashboard, Policy Configuration, and Agent
(Read Only) Events.

b. Agentinstaller package download available.
C. Modify their own account password.
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Server Accounts Overview

TXOne StellarOne features web console accounts with different privileges and
limitations. Use these accounts to configure StellarOne and to monitor or manage
StellarProtect agents. The following table outlines typical StellarOne tasks and
the account privileges required to perform them.

Task Account Privilege Allowed

Admin Operator Viewer
\Y

Dashboard

Configure application lockdown

Configure maintenance mode

Configure device control
Add trusted files
Add trusted USB devices

Scan now

Update approved list

Update agent components

Deploy agent patch

Check connection

Collect event logs

Import / Export (approved list / agent
configuration)

Organize (edit description / move /
delete)

Configure group policy

<| < <I << << < << << <] <<
<| < <I << << < << << <] <<
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Task

Account Privilege Allowed

Admin

Operator

Viewer

Configure global policy

\Y

Monitor agent event logs

Monitor server event logs

Monitor system logs

Monitor audit logs

\Y
\Y
\%
\Y

/Account management

Single Sign-On

System time

Syslog forwarding

Log purge

Schedule report

Notification settings

SMTP settings

Proxy settings

Downloads / Updates

< < < < <] <] <<

Firmware

SSL Certificate

License management

< < < < < < << < << << << <] <<
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Adding Accounts

Procedure

1.

2.

Log on to the web console using an administrator account.

(Please note that information entered here is case-sensitive)

Go to Administration > Account Management in the navigation

at the top of the web console. The Account Management screen

will appear.

Click Add User button, and the Add User Account screen will

appear.

Specify the Authentication Source. (Local or SMAL Identity

Provider)

. To add a local user, specify the ID and Name. (Please
note that information entered here is case-sensitive)

Add User Account

Authentication Source Local A
Role Viewer -
ID* Joseph
Name* Joseph Lin

. To add an SAML Identity Provider user, specify Email

for SAML Account Mapping and Name. (Please note
that information entered here is case- sensitive)
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Add User Account

Authentication Source SAML Identity Provider

Single Sign On Configuratior

Role Admin

Email for SAML Account Mapping® | molly_smith@samitest.com

sr case as the ace

Name Molly Smith

Role: Specify the privileges for the account as among Admin,

Operator or Viewer (Default).

Add User Account

Authentication Source Local

Role Viewer
ID* Admin
Operator

Name*

v Viewer
Local Password® sssssnes

. For a Local user, specify and re-type the Local
Password.

Group Control: Specify the Group Control you want for the

target account to access.
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Group Control* [ ] Al

[ Admin-G1 (0)
msmith-G1 (0’

~ [ Orson-G1 (0)
v [] Orson-G2 (0)

Orson-G3 (0)

[ Oscar-G1 (0)
Sammy-G1 (0)

7. Optionally, type an account Description.
8. Click Confirm button, and the target user account will be
created.

Account Management

Users Roles

+ Add User 1 2] /=
[+ Name Role Authentication Source Group Control Description Actions
Alice Admin-01 Admin Local ' |
Orson Operator-01 Operalor Local /|
Oscar Operator-02 Operator Local Fa |

66



Secured by

= Lxone

Edit Accounts

Procedure

1.

2.

Log on to the web console using an account with Admin role.
(Please note that information entered here is case-sensitive)

Go to Administration > Account Management in the navigation
at the top of the web console. The Account Management screen
will appear.

Click Edit icon from Actions, and the Edit User Account screen
will appear.

For a Local user, you can specify the account Role, Name,
Password, Group Control, and Description.

For a SAML Identity Provider user, you can specify the account
Role, Name, Group Control, and Description.

Click Confirm.

67



Secured by

23 txOne

networks

Edit User Account X

Authentication Source

Role Operator -

Email for SAML Account  Kimikof@samltest, com

Mapping* Type the same letter case as the account on your authentication server.
Name* Operator-01
Group Control* [ Aoy
[ Admin-G1 (0)
[] msmith-G1 (0)
> Orson-G1 (0)
[] Oscar-G1 (0)

[ ] sammy-G1 (0)

Description

Confirm Cancel
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Delete Accounts

Procedure

1. Log on the web console using an administrator account. (Please
note that information entered here is case-sensitive)

2. Go to Administration > Account Management in the navigation
at the top of the web console. The Account Management screen
will appear.

3. Select the specific account which you want to delete. (Only the
Master admin cannot be deleted)

Dashboard Agents Logs ¥ Administration ~ About

Account Management

Users Roles

[+ Add user
] ID Name Role Authentication Source Group Control Description Actions
admin admin Admin Local Al - s’
[ alice Admin-01 Admin Local Al - /B
4, Click Delete icon, and the Delete User Account dialog will
appear.
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Delete User Account X

Are you sure you want to delete the selected
account(s)?

Click Confirm button, and the target user account should be
deleted from the Account table.
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Single Sign-On

Procedure

1.

2.

Log on to the web console using an administrator account.
(Please note that information entered here is case-sensitive)

Go to Administration > Single Sign-On in the navigation at the
top of the web console.

Click Download button to download the StellarOne metadata
XML file.

Upload the StellarOne XML file to your IdP, and then download
the IdP metadata XML file.

Click Upload button to upload the IdP metadata XML file to
StellarOne web console and complete the SAML 2.0 single sign-
on configuration. The IdP metadata XML file must be re-
uploaded if there is a configuration change on the I1dP

3 ) Upload the |dP metadata XML file

Upload the IdP metadata XML file to complete the SAML 2 0 single sign-on configuration The IdP metadata XML file must be re-uploaded if there is a configuration change on the IdP.

pload Test Connectior

IdP display name:

Protocal” SAML 2 0/SAML 11
IdP Single Sign On URL

Mapping Attribute: Email Address

After the IdP metadata XML file is uploaded, the Test
Connection button will appear.

Click Test Connection button to test the IdP connection with
StellarOne.
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Dashboard Agents Logs ~ Administration «
Single Sign-On +" IdP connection test successful.
SAML Configuration

(1) Download the StellarOne metadata XML file
~—" Upload the StellarOne XML file to your IdP

&, Download

Note:

Invalid logon error message may appear after the SAML configuration is completed.
Please refer to Resolving the SSO Issue to check email setting in IdP server, and
system time synchronization in IdP and StellarOne servers.

Resolving the SSO Issue

Procedure

1. Open the Users folder under Active Directory Users and
Computers in IdP server.

2. Right-click on the user account used for SSO, then go to
Properties > General.

3. Check the E-mail field. Make sure the email input here is
consistent with the account email for accessing StellarOne web
console.
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File Action View Help
& 7FE /B XECLR HRETRETER
] Active Directory Users and Com|| Name Type Description Al
g ::‘;Ied Cuenes & Administrator User Built-in account for ad...
v 53 stellarone.com
Allov Ad
% Builtin %c :‘
€l
== [C)omp}Jtecrs ol ggqon Organization Member Of Dialin Environment Sessions
. ome oS 2 Deni Remote control Remote Desktop Services Profile COM+
_ ForeignSecurityPrincipal: General . =
3 EB Dns# Address Account Profile Telephones Delegation
| Managed Service Accour, be
Dnsl
alides &BDom a Administrator
@
%Dom
Boom .
First name: [ ] Inttials [ ‘
%Dom
%Dom Last name. { ]
%Entel - ] l
EB Ente| Y e ]
% Entel  Description: ‘Buihn account for administering the computer/domz‘
%Grou 7
E.;Gues Office: [ ]
B Key )
& pdgt Telephone number. l |
’.‘EPrott
< > || B RAS ’Email: [ ] ‘ |
——— 7 | | -

Make sure the system time in IdP and StellarOne servers are

synchronized. Below are suggested procedures for time
synchronization setting.
a. Ensure the time in IdP server synchronizes with the host PC

that runs the StellarOne Virtual Machine (VM).

b. Open the VM settings of StellarOne. Go to Options >
VMware Tools.
c. Check the box of Synchronize guest time with host, and
then click OK.
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Virtual Machine Settings

Hardware Options

Settings

[ General

b Fower

m Shared Folders
af Snapshots

£T) AutoProtect

&) Guest Isolation
[_'L__‘Access Control
IE‘VMwa re Tools
@VNC Connections
[ unity

[2=] Appliance View
Sp Autologin

B Advanced

Summary
51_1.2.2100

Disabled
Disabled
Mot encrypted

Time sync off
Disabled

Mot supported
Default/Default
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VMware Tools features

‘ Synchronize guest time with host

VMware Tools updates

If a new version of VMware Tools is available:

(O) Update manually (do nothing)

() update automatically

(@) Use application default (currently update manually)

To change the default setting, go to Edit > Preferences =
Updates
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Go to Administration > System Time to change system time settings.

Date and Time

Use the Time Period drop-down button to specific system time

Date and Time

Current Time: 2022—02—2?T18:19:38+08:DD‘ V4 ‘

B 2022-02-27 © 18:19:31

< February 2022
Time Zone

Su Mo Tu We Th Fr

Time Zone:  (GMT+08:00) Asia/Taipei
1 2 3 4
6 I 8 9 10 1l

13 14 15 16 17 18
20 M
O -
Apply Cancel

2 23 24 2%
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Time Zone

Use the drop-down to specific system time zone.

Time Zone

Time Zone: | (GMT+08:00) Asia/Taipe - |®

(GMT-12:00) Etc/GMT+12
(GMT-11:00) Etc/GMT+11
(GMT-11:00) Pacific/Midway
(GMT-11:00) Pacific/Niue
(GMT-11:00) Pacific/Pago_Pago
{GMT-11:00) Pacific/Samoa
(GMT-11:00) US/Samoa

(

GMT-10:00) Etc/GMT+10

(EMTAN-NNY HET
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Syslog Forwarding

You can forward Server and Agent Event logs to an external Syslog server for
the additional managing and monitoring capabilities. TXOne StellarOne console
forwards logs in the Common Event Format (CEF). Make sure your Syslog server
supports the Common Event Format (CEF).

Procedure
1. Go to Administration > Syslog Forwarding.
2. Enable Forward logs to syslog server (CEF only).
3 Specify the Protocol, Server Address, and Port of the Syslog
server.

Dashboard Agents Logs ~ Administration ¥

Syslog Forwarding

@ ) Forward logs to syslog server (CEF only)

Server Address® 10.1.195.79
Port* 601 @
Protocol QO TCcP () UDP

Save Cancel
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Agent event format

CEF Field Name Description
Header

CEF:Version

Device Vendor

Device Product

Device Version

Device Event Class ID = Event id

Name Event kind

Severity LOG_CRIT: 2
LOG_WARNING: 4
LOG_INFO: 6

Extension

eventTime StellarEnforce format

msg <string>

category OPTION: 0
SYSTEM: 1
INTELLI_AV: 2
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Possible Values

CEF:0

TXOne Networks
StellarProtect

1.0

{

Agent Event

{2, 4, 6}

Jan 02 2006 15:04:05
GMT+00:00



CEF Field Name

agentEndpoint
agentlp
agentLocation
agentVendor
agentModel
agentOS
policyVersion
detailMsg
targetProcess
fileHash
threatType
threatName
filePath
actionResult

quarantinePath

- Secured by
=) tExOne
. networks

Description Possible Values

ANOMALY_DETECT: 3
CHANGE_CONTROL: 4
DEVICE_CONTROL: 5
MISC: 15

<string>
<string>
<string>
<string>
<string>
<string>
<string>
<string>
<string>
<string>
<string>
<string>
<string>
<int>

<string>
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CEF Field Name Description Possible Values
obadMode <string>
obadLevel <string>
accessUser <string>
processid <string>
parentProcessl <string>
parentProcess?2 <string>
parentProcess3 <string>
parentProcess4 <string>
targetArguments <string>
parentArgumentsl <string>
parentArguments2 <string>
parentArguments3 <string>
parentArguments4 <string>
blockedProcess <string>
targetFile <string>
vid <int>
pid <int>
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CEF Field Name
sn
accesslmagePath
srcPath

dstPath

errCode
patchFileName

filePath

type

StellarProtect Server event format

CEF Field Name
Header
CEF:Version
Device Vendor
Device Product
Device Version

Device Event Class
ID

Description

<string>
<string>
<string>
<string>
<int>

<string>
<string>

<string>

Description

Event id

Secured by
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Possible Values

Possible Values

CEF:0
TXOne Networks
StellarProtect

1.0
{



CEF Field Name
Name

Severity
Extension

eventTime

msg
userName
userRole

clientlp

StellarOne Server event format

CEF Field Name
Header
CEF:Version
Device Vendor
Device Product

Device Version

Description

Event kind

LOG_INFO:

StellarEnforce format

<string>
<string>
<string>

<string>

Description

6
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Possible Values

Server Event

{6}

Jan 02 2006 15:04:05
GMT+00:00

Possible VValues

CEF:0
TXOne Networks
StellarOne

1.0
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CEF Field Name Description Possible Values

Device Event Class Event id {}

ID

Name Event kind Console Log

Severity LOG_INFO: 6 {6}

Extension

eventTime StellarEnforce format = Jan 02 2006 15:04:05

GMT+00:00

msg <string>

userName <string>

userRole <string>

clientlp <string>

status UNSPECIFIED: 0 {0, 1, 2}
AU_SUCCESS: 1
AU_FAIL: 2

product <string> {protect, enforce}
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Log Purge Settings

Purge older logs to reduce the size of the StellarOne database.

Purge Now
Procedure
1. Go to Administration > Log Purge in the navigation at the top
of the web console. The Log Purge screen will appear.
2. Specify the Log Type you want to purge below.
. All Logs
. System Log, Audit Log, Agent Events, or Server Events
3. Under older than, specify the maximum age of event log entries
to keep.
. No limit
. 1 month(s), 2 months(s), 3 months(s), 6 months(s), 12
months(s), 18 months(s), 24 months(s), 36 months(s), 48
months(s), 60 months(s)
4, Under Keep at most, specify the maximum number of event
entries to keep.
. 0 entries
. 10000 entries, 50000 entries, 100000 entries, 500000
entries, 1000000 entries, 5000000 entries, 10000000
entries
5. Click Purge Now button, and the event logs should be purged.
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Log Purge

Purge Now

Purge AgentEvents ¥ olderthan nolimit ¥ and keep at most = O enfries ~

Purge Now

Purge AgentEvents ¥ olderthan 1 month(s) ¥ andkeep atmost 10,000 entries ~

Automatic Purge

Use these settings to set an automatic purge once per day.

Procedure
1. Go to Administration > Log Purge in the navigation at the top
of the web console. The Log Purge screen will appear.
2. Specify the Log Type you want to purge below.
. System Log
. Audit Log
. Agent Events
. Server Events
3. Under older than, specify the maximum age of event log entries
to keep.
. No limit
. 1 month(s), 2 months(s), 3 months(s), 6 months(s), 12
months(s), 18 months(s), 24 months(s), 36 months(s), 48
months(s), 60 months(s)
4. Under Keep at most, specify the maximum number of event
entries to keep.
. 10000 entries
. 50000 entries
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. 100000 entries

. 500000 entries

. 1000000 entries

. 5000000 entries

. 10000000 entries
5. Click Save button.

Automatic Purge

Purge System Log olderthan nolimit ¥ and keep at most 10,000 entries ~
Purge AuditLog olderthan nolimit ¥ and keep at most 10,000 entries ~
Furge Server Events olderthan nolimit * and keep at most 10,000 enfries ~

Purge Agent Events olderthan nolimit ~ and keep atmost 10,000 enfries ~

Save | Cancel |

Notification Settings

Enter your e-mail under Email Notifications. Your e-mail will be saved when you
Save the page with the rest of your settings.

Procedure
1. First, go to Administration > SMTP Settings to specify your
SMTP server settings.
2. Go to Administration > Notification to change notification
settings.
3. Sections under Notification include:
. Warning Level Agent Events
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Outbreak
Email Notifications.
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Warning Level Agent Events

When the switch under Warning Level Agent Events is enabled, StellarOne
console will send a notification to your Email when an incident happens that
triggers a “Warning”.

2 TXOne StellarProtect: [Action required] Incoming Files Scanned, Action Taken by Antivirus: C:\Users\Administrator\Desktop\eicar\eicar.com on TC

StellarOne

Action required

TXOne StellarProtect detected a warning event that requires attenfion. Incoming Files Scanned, Acfion Taken by Anfivirus:
Cusers\Administraton\Deskiop\eicar\eicar.com

To manage this event, go to Agent Event.

Event Information

Date and Time: 2022-03-16T07:21:55Z

Level Warmning

Event ID: 4609

Event Incoming Files Scanned, Action Taken by Antivirus: C:\Users\Administrator\Desktop\eicarieic
ar.com

Detail: Incoming files were scanned by antivirus. Actlon were taken according to setfings.
File Path: C:\U \eicar.com

File Hash: 275a021bbib6489e54d47189917db9d 1663fc695ec2ie2a2c4538aabi65 11d0i
Threat Type: Virus

Threat Name: Eicar_est_file

Action Result: 0

Quarantine Path- C\Program Files\TXOx P 2121-19d9-43
d5-aa93-36aaB997 5491
Agent Information
Endpoint TC
IP address: 192.168.15.138
Tags
Approved List last updated on NIA

Outbreak

When the switch under Outbreak is enabled, StellarOne console will send a
notification to your Email when more than a specified number of open warning
messages has appeared in a specified time period.
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StellarOne(protect): Outbreak notification

StellarOne

Outbreak on 2022-03-16 07:32:23.113205781 +0000 UTC m=+17362.839585743. There were more than 1 warnings within a 1-minute period.
For details, go to the StellarOne web console at Agent Event

You can set the number of open warnings in a time period to be considered as an
outbreak (1 - 20000), as well as the time period which those warnings will be
measured against (1 - 60 minutes).

Outhreak

(:_Z' Send outbreak notifications

Number of warnings in a time period: 10 (1-20000)

The time period of those warnings: 1 (1-60 minutes)
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SMTP Settings

This screen allows users to specify SMTP server settings for sending out
notifications and scheduled reports.

Procedure

1. Go to Administration > SMTP Settings in the navigation at the
top of the web console. The SMTP Settings screen will appear.

2. Specify Server address, Port, and Sender.

3. If the SMTP server requires authentication, select SMTP server
requires authentication.

4. To send a test email from StellarOne, click the Send Test Emaiil
button.

5. Click Save button.

Dashboard Agents Logs * Administration

SMTP Settings

Server address:*

Port:*

Sender:”
SMTP server requires authentication

User name*

Password®

Cancel Send Test Email
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Proxy Settings

There are three proxy settings, Proxy Settings for StellarOne to internet, Proxy
settings for StellarOne to Agent communications and Proxy Settings for agent to
StellarOne communicates to agents.

Procedure

1.

2.

Go to Administration > Proxy in the navigation at the top of the
web console.
Specify the Proxy Settings for the following option:

. Proxy Settings for StellarOne to internet

. Proxy settings for StellarOne to Agent communications

. Proxy Settings for agent to StellarOne communicates to
agents.

To configure proxy settings for updates:

(1) Select protocol use HTTPS or HTTP

(2) Under Server Address, specify the IPv4 address or FQDN
of the proxy server.

(3) Specify the Port.

(4) If your proxy server requires authentication, select Proxy
server authentication and give your credentials.

(5) Click Save.
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Dashboard Agents : Administration ~ About

Proxy

Proxy Settings for StellarOne to internet
@ Proxy Settings for StellarOne to internet
O HTTPS O HTTP
Server Address®
Port*
@) Proxy server requires authentication

User name*

Password*®

Proxy Settings for StellarOne to Agent communications

L Proxy Settings for StellarOne to Agent communications

Proxy Settings for Agent to StellarOne communications

(1 Proxy Settings for Agent to StellarOne communications
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Y Tip

To configure proxy settings used by StellarOne when sending messages to
StellarProtect.

Before installation:

Add the proxy information to the configuration file used by the agent installer package.
Save the proxy settings. They will now be included in the agent installer after the agent
package is repacked.

After installation:

Use the opcmd.exe Command Line Interface tool on the local StellarProtect agent
administrator guide.
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Download / Update Settings

To manage Download / Updates for StellarOne and StellarProtect, go to
Administration >

Download / Updates in the navigation at the top of the web console. Here, you
have two tabs: StellarOne and StellarProtect.

The following table describes the tasks you can perform on this screen under the
StellarOne tab:

Function Description

Scan Component Under this section you can click Update Now to
downloading latest components. All of the pattern and
engine versions are listed here.

Scan Component Set the frequency and time for scheduled reports to be

Update Schedule either daily, weekly, or monthly, as well as which day of
the week or month they arrive on and Start time.

Scan Component Specify an update server or download updates directly

Update Source from the ActiveUpdate server.

(StellarOne)

Scan Component You can also specify an update server or downloading

Update Source (Agents) them directly from StellarOne.

The following table describes the tasks you can perform on this screen under the
StellarProtect tab:

Function Description

Download StellarProtect Download an up-to-date agent installer package. You
Agent Installer Package |can also modify the agent component download source
and proxy settings, as well as update to the latest
components.
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Function Description

Download a Group.ini file and add it into the installer
package, which enables directly registering
StellarProtect agent to a specific group via StellarOne
console. For more details, see Group Mapping.

Patch Here you can click the Import button to import a patch
manually, or Delete to remove a StellarProtect patch.

Group Mapping
Procedure

1. Goto Administration > Downloads/Updates in the navigation at the
top of the web console.

2. Select StellarProtect tab.
3. After downloading the Installer Package, click on download Group.ini.

stellarOne

Dashboard Agents Logs - Administration ~

Downloads/Updates
StellarOne StellarProtect StellarEnforce

Download StellarProtect Agent Installer Package

(@ If the communication between StellarOne and StellarProtect uses proxy, configure the settings on the Proxy page before
downloading the installer package.

(@ To register Agent to a specific group directly, you canjdow
package

with the group I1D and name, then add it into the installer

‘ &, Download

4. Select a group for the StellarProtect agent and click Download. A file
named Group.ini is downloaded. Place the Group.ini file as the top-
level file in the agent’s installer package.
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Select a group

Group Name N
All (22

> © AMEA (0

> Asia (0
ceeeec (0

> Europe (0

> HAWAII (2
hello (C

>
Not_exist_agents (2
peter (2
tc (0
tmps-test-asia (1
Z1-L1 (0
Z1-L2 (1
Z1-L3 (0
ZenShareViolate (2

__j Group.ini ~

5. User can check StellarOne management console and StellarProtect
agent console to see if the agent is successfully registered.
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Firmware
Procedure
1. Go to Administration > Firmware in the navigation at the top of
the web console.
2. Click Import to specify the firmware patch file (E.g.
acus.fw_1.2.0137.acf).
3. Version shows the current StellarOne build version.
4. Release Date and Description show the current information for

StellarOne patch fire.

Firmware Update X

Version 1.2.0137

Release Date 2022-02-27T02:39:21+08:00

Description 100137

5. When the Firmware Update window pops up, click Apply to
apply the patch to StellarOne.

6. Confirm the notification description.
7. Click Install Now to implement the update or Abort to stop
updating.
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Administration = Firmware

Firmware

Update downloaded. StellarOne is ready to install. Please click the Install button to start the installation, After
completing Installation, the system may restart all services.

Notice

= The installation may take 5 to 10 minutes to finish. Please do not shut down the StellarOne during the
installation

* We highly recommended you to back up your data before starting the installation,

» The system will not support downgrading to an earlier version.

o Install Now ® Abort
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SSL Certification
Procedure
1. Go to Administration > SSL Certification in the navigation at
the top of the web console.
2. Select the desired Import Certificate.
3. Importing the certificate requires restarting the virtual instance.

(1) Use the ‘Select file...” dropdown next to Certificate to
select the desired certificate to import.

(2) Use the ‘Select file...” dropdown next to Private Key to
select the desired Private Key.

3) Specify the Passphrase. (Optional)

Import Certificate X

Note: Importing the certificate requires restarting the virtual instance.

Certificate™ Selectfile ... SSLCERT.crt

Private Key* Selectfile ... SSLCERTkey

Passphrase ssssssse |
4, Click Import and Restart. (StellarOne console will be reloaded)
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Dashboard Agents Logs ~ Administration « About

SSL Certificate

Certificate CN=haha,OU=5tellar,0=TXOne,L=Taipei, ST=Taipei,C=TW
Issuer CMN=haha, OU=Stellar. O=TXOne L=Taipel ST=Taipel, C=TW
Expiration 2022-09-15T17:36:13+08200

M Remove Certificate ‘ ‘ & Replace Certificate
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License Management

To display the License Management screen, go to Administration > License in
the navigation at the top of the web console. The following details appear on this
screen:

Iltem Description
Status Displays “Activated” or “Expired”
Type Displays “Full” or “Trial”
Expiration Displays the date when features and support end
Seats Specifies how many agents can register to StellarOne and
current number of registered agents
Activation Code |Displays the Activation Code
Last Updated Displays the last time the Activation Code was updated
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Changing Activation Code

Dashboard Agents Logs ¥ Administration ~

License

-+ Specify Activation Code £ Renew License

StellarEnforce

Status: Activated
Type: Trial
Expiration: 2022-03-31
Seats: 1/5

Activation Code: T -EEreg.d == P AT AT T

Last Updated:  2022-02-27T22:52:56+08:00

Procedure

1. Go to Administration > License in the navigation at the top of the
web console. The License Management screen will appear.

2. Click Specify Activation Code button.

3. Input the target new Activation Code to renew for StellarOne console.
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—’gNote:

Click Renew License button to update your product license. The connection with the
TXOne Product License server is required.
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Chapter 8

Log Description Reference

This chapter includes extra information for administrator management.Topics in
this chapter include:

- StellarProtect Agent Event Log Descriptions

e StellarProtect Server Event Log Descriptions

- StellarOne Server Event Log Descriptions
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StellarProtect Agent Event Log Descriptions

Windows Event Log Descriptions

Event |Level Category|Event Content Event Details
ID
256 Informationjsystem  [Service started
257 Informationjsystem  |Policy applied
successfully (Version:
Y%version%)
258 Informationjsystem  |Patch applied. File Name: |Patch applied.
%%file_name% File Name: %file_name%
259 Information|system Patching in progress Patching in progress.
/After the earlier-applied patch
is completed, the system will
automatically try to apply this
patch: %deferred_file_name%
513 Informationfintelli_av |ICS Inventory List Update
Succeeded
514 Informationfintelli_av |Real Time Scan Enabled
515 Informationfintelli_av [Scheduled Scan Start /A scheduled scan has started.
516 Informationfintelli_av |Scheduled Scan End /A scheduled scan has ended.
517 Informationfintelli_av |On-Demand Scan Start  |A manually launched scan has
started.
518 Informationfintelli_av |On-Demand Scan End  |A manually launched scan has
ended.
519 Informationfintelli_av [Scheduled Scan Enabled |Scheduled scan has been
enabled.
Next scan will be on
%NextScan%.
520 Informationfintelli_av [Scheduled Scan Disabled |Scheduled scan has been

disabled.
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Event |Level Category|Event Content Event Details
ID
768 Informationjanomaly_ |Operations Mode: %Mode%
detect Behavior Anomaly Level: %Level%
Detection Enabled
769 Informationjanomaly_ |Added Operations Access User: %USERNAME?
detect Behavior Anomaly ID: %ID%
Detection Approved Target Process: %PATHY%
Operation %ARGUMENT%
Parent Process 1: %PATH%
%ARGUMENT%
Parent Process 2: %PATH%
%ARGUMENT%
Parent Process 3: %PATH%
%ARGUMENT%
Parent Process 4: %PATH%
%ARGUMENT%
770 Informationjanomaly_ |Removed Operations ID: %ID%
detect Behavior Anomaly Target Process: %PATH%
Detection Approved BWARGUMENT%
Operation Parent Process 1: %PATHY%
%ARGUMENT%
Parent Process 2: %PATH%
%ARGUMENT%
Parent Process 3: %PATH%
Parent Process 4: %PATH%
%ARGUMENT%
784 Informationjanomaly_ |[DLL Injection Prevention
detect Enabled
1280 |Information|device_co [Device Control Enabled
ntrol
1281  |Information|device co [Trusted USB Device Vendor ID: %HEX%
ntrol Added Product ID: %HEX%

Serial Number: %STRING%

Type: permanent or one time
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Event |Level Category|Event Content Event Details
ID
1282  |Information|device co [Trusted USB Device Vendor ID: %HEX%
ntrol Removed Product ID: %HEX%
Serial Number: %STRING%
4352  |Warning |system  |Service stopped
4353  |Warning  [system Unable to apply policy
(Version:
Ybversion%)
4609  Warning |intelli_av |Incoming Files Scanned, [Incoming files were scannedby
Action Taken by antivirus. Actions were taken
Antivirus: %PATH% according to settings. File Path
%PATH%
File Hash: %STRING%
Threat Type: %STRING%
Threat Name: %STRING%
Action Result: %INTEGER%
Quarantine Path: %PATH%
4610  |Warning intelli_av |Incoming Files Scanned, (Incoming files were scanned b
ActionTaken by Next-  [next-generation antivirus.
Generation Antivirus: Actions were taken according
%PATH% to settings.
File Path: %PATH%
File Hash: %STRING%
Threat Type: %STRING%
Threat Name: %STRING%
Action Result: %INTEGER%
Quarantine Path: %PATH%
4612  |Warning |intelli_av |Local Files Scanned, Local files were scanned by

Action Taken by Next-
Generation Antivirus:
%PATHY%

next- generation antivirus.
Actions were taken according
to settings.

File Path: %PATH%

File Hash: %STRING%

Threat Type: %STRING%
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Event |Level Category|Event Content Event Details
ID
Threat Name: %STRING%
Action Result: %INTEGER%
Quarantine Path: %PATH%
4613  \Warning (intelli_av [Suspicious Program Suspicious program execution
Execution Blocked: was blocked.
%PATH% File Path: %PATH%
File Hash: %STRING%
4614  \Warning intelli_av [Suspicious Program Suspicious program is currentl
Currently Running: running.
%PATH% Process Id: %PID%
File Path: %PATH%
File Hash: %STRING%
File Credibility: %STRING%
4615  \Warning |intelli_av |Application Execution  |Application execution was
Blocked By Antivirus:  [plocked by antivirus.
Y%PATH% Target Process: %PATH%
File Hash: %STRING%
Threat Type: %STRING%
Threat Name: %STRING%
4617  |Warning |intelli_av |Application Execution  |Application execution was
Blocked By Next- blocked by next- generation
Generation Antivirus: antivirus.
Y%PATH% Target Process: %PATH%
File Hash: %STRING%
Threat Type: %STRING%
Threat Name: %STRING%
4864  |Warning lanomaly_ |Operations Behavior
detect Anomaly

Detection Disabled
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Event |Level Category|Event Content Event Details
ID
4865  |Warning janomaly_ |Process Allowed by Access User:
detect Operations Behavior %USERNAME%
AnomalyDetection: Parent Process 1: %PATH%
%PATH% %ARGUMENT%
%ARGUMENT% Parent Process 2: %PATH%
%ARGUMENT%
Parent Process 3: %PATH%
%ARGUMENT%
Parent Process 4: %PATH%
%ARGUMENT%
Mode: %Mode%
4866  |Warning lanomaly_ |Process Blocked by Access User:
detect Operations Behavior %USERNAME%
Anomaly Detection: Parent Process 1: %PATH%
%PATH% %ARGUMENT%
Y%ARGUMENT% Parent Process 2: %PATH%
%ARGUMENT%
Parent Process 3: %PATH%
%ARGUMENT%
Parent Process 4: %PATH%
%ARGUMENT%
Mode: %Mode%
4880 |Warning janomaly_ |DLL Injection Prevention
detect Disabled
5120  |Warning |change_co|ICS File Change Blocked |ICS File change to executable
ntrol by SafeGuard: file were blocked by
%PATH% SafeGuard.

Blocked Process: %PATH%

Target File: %PATH%
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Event |Level Category|Event Content Event Details
ID
5121  |Warning |change_co|ICS Process Manipulation|ICS Process manipulation wer
ntrol Blocked by Safeguard:  |blocked by Safeguard:
%PATH% Blocked Process: %PATH%
Target Process: %PATH%
5376  |Warning |device_co [Device Control Disabled
ntrol
5377  |Warning (device_co [USB Access Blocked:  |Access Image Path: %PATH%
ntrol %PATHY% Access User: %USERNAME?
Vendor ID: %HEX%
Product ID: %HEX%
Serial Number: %STRING%
8706  [Critical intelli_av |Real Time Scan Disabled
9216  |(Critical change_co|Maintenance Mode Start
ntrol
9217  |(Critical change_co|Maintenance Mode End
ntrol
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StellarProtect Server Event Log Descriptions

Server Event Log Descriptions

ID

33027
33028
33029
33041

33042

33043

33044

33045

33046

33047

33048

Content

Switch agent (%s) to policy mode
Switch agent (%s) to individual mode
Deploy policy with version: %s

Modify in common use (DLL Injection Prevention, USB Vector
Control, ICS Application Safeguard, OBAD) setting for [%s] group
policy with version: %s

Modify real-time scan settings for [%s] group policywith version: %s
Modify schedule scan settings for [%s] group policywith version: %s

Maintain USB Vector Control list for [%s] group policywith version:
%s

Maintain User Defined Suspicious Object list for [%s] group policy
with version: %s

Maintain Operations Behavior Anomaly Detection Watch Listfor
[%s] group policy with version: %s

Maintain Trusted Certification list for [%s] group policywith version:
%s

Maintain ICS Application Safeguard list for [%s] group policywith
version: %s
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33106
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Modify agent password for [%s] group policy with version: %s
Modify available patch setting for [%s] group policywith version: %s
Send individual command to agent (%s)

Send protection command <Configure Change Window> to agents
Send protection command <Scan Now> to agents

Send protection command <Update Component> to agents

Send protection command <Apply Patch> to agents

Send event action to agent (%s)
Set activation code with policy version: %s
Active agents

Inactive agents
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StellarOne Server Event Log Descriptions

Server Event Log Descriptions

ID

45313
45314
45315
45316
45317
45318
45319
45320
45321
45322

45323

45324

Content

Scan component update now

Scan component [%s] update job was started

Enable scan component scheduled update

Disable scan component scheduled update

Modify scan component update source for StellarOne

Modify scan component update source for agents

Scan component [%s] update was successful

Scan component [%s] update was successful but no duplicate needed
Scan component [%s] update was failed with internal error

Scan component [%s] update was failed due to unable to connect to the
network

Customize policy

Inherit policy from [%s]
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Chapter 9

Technical Support

TXOne Networks is a joint venture of Trend Micro and Moxa, andsupport for TXOne
Networks products is provided by Trend Micro. All technical support goes through
Trend Micro engineers.

This chapter includes information about troubleshooting, contacting

Trend Micro, sending suspicious content to Trend Micro, and other
resources.
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Troubleshooting Resources

Before contacting technical support, consider visiting the followingTrend Micro
online resources.
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Using the Support Portal

The Trend Micro Support Portal is a 24/7 online resource thatcontains the most
up-to-date information about both common and unusual problems.

Procedure

1. Go to http://success.trendmicro.com/.

2. Select from the available
products or click theappropriate
button to search for solutions.

3. Use the Search Support box to search for available solutions.

4. If no solution is found, click Contact Support
and select the type of support needed.

Q Tip

To submit a support case online, visit the following URL:

https://success.trendmicro.com/sign-in

A Trend Micro support engineer will investigate the case and respond in 24
hours or less.
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Threat Encyclopedia

Most malware today consists of blended threats, which combinetwo or more
technologies, to bypass computer security protocols. Trend Micro and TXOne
combat this complex malware with products that createa custom defense
strategy.

The Threat Encyclopedia provides a comprehensive list of namesand
symptoms for various blended threats, including known malware, spam,
malicious URLs, and known vulnerabilities.

Go to https://www.trendmicro.com/vinfo/us/threat-encyclopedia/ to learn more
about:

Malware and malicious mobile code currently active or "in the wild"

«  Correlated threat information pages to form a
complete web attackstory

Internet threat advisories about targeted attacks and security
threats

. Web attack and online trend information

Weekly malware reports
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Contacting Trend Micro

In the United States, Trend Micro representatives are available byphone or
email:

Address Trend Micro, Incorporated

225 E. John Carpenter Freeway, Suite

1500Irving, Texas 75062 U.S.A.
Phone Phone: +1 (817) 569-8900

Toll-free: (888) 762-8736

Website http://www.trendmicro.com

Email address | support@trendmicro.com

Worldwide support offices: http://www.trendmicro.com/us/about-

us/contact/index.html

TXOne product documentation: http://docs.trendmicro.com
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Speeding Up the Support Call

To improve problem resolution, have the following informationavailable:
Steps to reproduce the problem
. Appliance or network information

Computer brand, model, and any additional connected hardware or
devices

Amount of memory and free hard disk space

Operating system and service pack version
«  Version of the installed agent

Serial number or Activation Code

Detailed description of install environment

Exact text of any error message received
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Sending Suspicious Content to Trend Micro

Several options are available for sending suspicious content toTrend Micro for
further analysis.

Email Reputation Services

Query the reputation of a specific IP address and nominate amessage transfer
agent for inclusion in the global approved list:

https://ers.trendmicro.com/
Refer to the following Knowledge Base entry to send messagesamples to TXOne:

http://esupport.trendmicro.com/solution/en-US/1112106.aspx

File Reputation Services

Gather system information and submit suspicious file content toTrend Micro:
http://esupport.trendmicro.com/solution/en-us/1059565.aspx

Please record the case number for tracking purposes.

Web Reputation Services

Query the safety rating and content type of a URL suspected of being a phishing
site, or other so-called "disease vector" (the intentionalsource of Internet
threats such as spyware and malware):

http://global.sitesafety.trendmicro.com/

If the assigned rating is incorrect, send a re-classification requestto Trend
Micro.
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Other Resources

In addition to solutions and support, there are many other helpfulresources
available online to stay up to date, learn about innovations, and be aware of
the latest security trends.

Download Center

From time to time, TXOne may release a patch for a reported known issue or an
upgrade that applies to a specific product or service.To find out whether any
patches are available, go to:

http://www.trendmicro.com/download/

If a patch has not been applied (patches are dated), open the Readme file to
determine whether it is relevant to your environment. TheReadme file also
contains installation instructions.

Documentation Feedback

TXOne always seeks to improve its documentation. If you havequestions,
comments, or suggestions about this or any TXOne document, please go to the
following site:

http://www.trendmicro.com/download/documentation/rating.asp
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